Re installation of OpenHIM Console

Hi Pau

The screenshot error message indicates to me that the module ‘load-grunt-tasks’ could not be found. This could be because it has not been installed. Can you confirm that you have followed the steps as indicated in the Developer Guide?

https://github.com/jembi/openhim-console

If all steps are followed correctly the installation should work without any problems.

Warm Regards,

Martin

···

On Mon, Oct 6, 2014 at 9:21 AM, Pau Racelis pau.racelis@gmail.com wrote:

Hi, Sir Martin!

I have a question to ask with regards to the installation of OpenHIM Console webapp. I have encountered this problem while following the steps. I cannot run the “grunt test” I am receiving this error. Thank you for your help!

Hi Pau

From what I can see on your last screenshot, you have started the core server correctly and is running. You can test this by running ‘npm test’

Can you also just include the openHIE mailing list to reach a greater audience for assistance with any issues.

Warm Regards,

Martin

···

On Mon, Oct 6, 2014 at 10:37 AM, Pau Racelis pau.racelis@gmail.com wrote:

also when I typed “node --harmony lib/server.js” this is what’s showing.

On Mon, Oct 6, 2014 at 1:28 AM, Pau Racelis pau.racelis@gmail.com wrote:

Hi!
I have another question, about the “cake watch” https://github.com/jembi/openhim-core-js What should we be seeing? Is this right?

On Mon, Oct 6, 2014 at 12:57 AM, Martin Brocker martin@jembi.org wrote:

Hi Pau

The screenshot error message indicates to me that the module ‘load-grunt-tasks’ could not be found. This could be because it has not been installed. Can you confirm that you have followed the steps as indicated in the Developer Guide?

https://github.com/jembi/openhim-console

If all steps are followed correctly the installation should work without any problems.

Warm Regards,

Martin

On Mon, Oct 6, 2014 at 9:21 AM, Pau Racelis pau.racelis@gmail.com wrote:

Hi, Sir Martin!

I have a question to ask with regards to the installation of OpenHIM Console webapp. I have encountered this problem while following the steps. I cannot run the “grunt test” I am receiving this error. Thank you for your help!

Hi Pau

I am including the mailing list in this response again to have a few more eyes looking at what could be causing this issue.
@Hannes @Duma have any of you guys run into this issue before and maybe know what could be causing it?

Warm reagrds,

Martin

···

On Mon, Oct 6, 2014 at 11:02 AM, Pau Racelis pau.racelis@gmail.com wrote:

I ran the ‘npm test’ and this happened

On Mon, Oct 6, 2014 at 1:43 AM, Martin Brocker martin@jembi.org wrote:

Hi Pau

From what I can see on your last screenshot, you have started the core server correctly and is running. You can test this by running ‘npm test’

Can you also just include the openHIE mailing list to reach a greater audience for assistance with any issues.

Warm Regards,

Martin

On Mon, Oct 6, 2014 at 10:37 AM, Pau Racelis pau.racelis@gmail.com wrote:

also when I typed “node --harmony lib/server.js” this is what’s showing.

On Mon, Oct 6, 2014 at 1:28 AM, Pau Racelis pau.racelis@gmail.com wrote:

Hi!
I have another question, about the “cake watch” https://github.com/jembi/openhim-core-js What should we be seeing? Is this right?

On Mon, Oct 6, 2014 at 12:57 AM, Martin Brocker martin@jembi.org wrote:

Hi Pau

The screenshot error message indicates to me that the module ‘load-grunt-tasks’ could not be found. This could be because it has not been installed. Can you confirm that you have followed the steps as indicated in the Developer Guide?

https://github.com/jembi/openhim-console

If all steps are followed correctly the installation should work without any problems.

Warm Regards,

Martin

On Mon, Oct 6, 2014 at 9:21 AM, Pau Racelis pau.racelis@gmail.com wrote:

Hi, Sir Martin!

I have a question to ask with regards to the installation of OpenHIM Console webapp. I have encountered this problem while following the steps. I cannot run the “grunt test” I am receiving this error. Thank you for your help!

Sorry the screenshots were not attached in my previous response:

Screenshot (73).pngScreenshot (72).png

···

On Mon, Oct 6, 2014 at 11:40 AM, Martin Brocker martin@jembi.org wrote:

Hi Pau

I am including the mailing list in this response again to have a few more eyes looking at what could be causing this issue.
@Hannes @Duma have any of you guys run into this issue before and maybe know what could be causing it?

Warm reagrds,

Martin

On Mon, Oct 6, 2014 at 11:02 AM, Pau Racelis pau.racelis@gmail.com wrote:

I ran the ‘npm test’ and this happened

On Mon, Oct 6, 2014 at 1:43 AM, Martin Brocker martin@jembi.org wrote:

Hi Pau

From what I can see on your last screenshot, you have started the core server correctly and is running. You can test this by running ‘npm test’

Can you also just include the openHIE mailing list to reach a greater audience for assistance with any issues.

Warm Regards,

Martin

On Mon, Oct 6, 2014 at 10:37 AM, Pau Racelis pau.racelis@gmail.com wrote:

also when I typed “node --harmony lib/server.js” this is what’s showing.

On Mon, Oct 6, 2014 at 1:28 AM, Pau Racelis pau.racelis@gmail.com wrote:

Hi!
I have another question, about the “cake watch” https://github.com/jembi/openhim-core-js What should we be seeing? Is this right?

On Mon, Oct 6, 2014 at 12:57 AM, Martin Brocker martin@jembi.org wrote:

Hi Pau

The screenshot error message indicates to me that the module ‘load-grunt-tasks’ could not be found. This could be because it has not been installed. Can you confirm that you have followed the steps as indicated in the Developer Guide?

https://github.com/jembi/openhim-console

If all steps are followed correctly the installation should work without any problems.

Warm Regards,

Martin

On Mon, Oct 6, 2014 at 9:21 AM, Pau Racelis pau.racelis@gmail.com wrote:

Hi, Sir Martin!

I have a question to ask with regards to the installation of OpenHIM Console webapp. I have encountered this problem while following the steps. I cannot run the “grunt test” I am receiving this error. Thank you for your help!

Hi Pau,

The EADDRINUSE flag indicates that one of the ports that the HIM is trying to bind to is already in use.

One possibility could be that it’s the HIM itself holding on to those ports, so first ensure that the HIM isn’t running when you try to run ‘npm test’.

This seems the most likely to me, since it sounded like you were able to run the HIM successfully earlier (i.e. node --harmony lib/server).

I would suggest first solving this issue and then re-running the tests to see if the second issue also goes away.

Cheers

Hannes

Screenshot (73).png

Screenshot (72).png

···

On 6 October 2014 11:43, Martin Brocker martin@jembi.org wrote:

Sorry the screenshots were not attached in my previous response:

You received this message because you are subscribed to the Google Groups “Interoperability Layer (OpenHIE)” group.

To unsubscribe from this group and stop receiving emails from it, send an email to openhie-interoperability-layer+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.


Hannes Venter

Senior Software Developer, Jembi Health Systems | SOUTH AFRICA

Mobile: +27 73 276 2848 | Office: +27 21 701 0939 | Skype: venter.johannes

E-mail: hannes@jembi.org

On Mon, Oct 6, 2014 at 11:40 AM, Martin Brocker martin@jembi.org wrote:

Hi Pau

I am including the mailing list in this response again to have a few more eyes looking at what could be causing this issue.
@Hannes @Duma have any of you guys run into this issue before and maybe know what could be causing it?

Warm reagrds,

Martin

On Mon, Oct 6, 2014 at 11:02 AM, Pau Racelis pau.racelis@gmail.com wrote:

I ran the ‘npm test’ and this happened

On Mon, Oct 6, 2014 at 1:43 AM, Martin Brocker martin@jembi.org wrote:

Hi Pau

From what I can see on your last screenshot, you have started the core server correctly and is running. You can test this by running ‘npm test’

Can you also just include the openHIE mailing list to reach a greater audience for assistance with any issues.

Warm Regards,

Martin

On Mon, Oct 6, 2014 at 10:37 AM, Pau Racelis pau.racelis@gmail.com wrote:

also when I typed “node --harmony lib/server.js” this is what’s showing.

On Mon, Oct 6, 2014 at 1:28 AM, Pau Racelis pau.racelis@gmail.com wrote:

Hi!
I have another question, about the “cake watch” https://github.com/jembi/openhim-core-js What should we be seeing? Is this right?

On Mon, Oct 6, 2014 at 12:57 AM, Martin Brocker martin@jembi.org wrote:

Hi Pau

The screenshot error message indicates to me that the module ‘load-grunt-tasks’ could not be found. This could be because it has not been installed. Can you confirm that you have followed the steps as indicated in the Developer Guide?

https://github.com/jembi/openhim-console

If all steps are followed correctly the installation should work without any problems.

Warm Regards,

Martin

On Mon, Oct 6, 2014 at 9:21 AM, Pau Racelis pau.racelis@gmail.com wrote:

Hi, Sir Martin!

I have a question to ask with regards to the installation of OpenHIM Console webapp. I have encountered this problem while following the steps. I cannot run the “grunt test” I am receiving this error. Thank you for your help!

Also make sure you delete the openhim-test mongo database, so that your tests have a clean slate to run from.

regards,

Duma Mtungwa

Screenshot (72).png

Screenshot (73).png

···

On Mon, Oct 6, 2014 at 11:56 AM, Hannes Venter hannes@jembi.org wrote:

Hi Pau,

The EADDRINUSE flag indicates that one of the ports that the HIM is trying to bind to is already in use.

One possibility could be that it’s the HIM itself holding on to those ports, so first ensure that the HIM isn’t running when you try to run ‘npm test’.

This seems the most likely to me, since it sounded like you were able to run the HIM successfully earlier (i.e. node --harmony lib/server).

I would suggest first solving this issue and then re-running the tests to see if the second issue also goes away.

Cheers

Hannes

You received this message because you are subscribed to the Google Groups “Interoperability Layer (OpenHIE)” group.

To unsubscribe from this group and stop receiving emails from it, send an email to openhie-interoperability-layer+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

On 6 October 2014 11:43, Martin Brocker martin@jembi.org wrote:

Sorry the screenshots were not attached in my previous response:

You received this message because you are subscribed to the Google Groups “Interoperability Layer (OpenHIE)” group.

To unsubscribe from this group and stop receiving emails from it, send an email to openhie-interoperability-layer+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

Hannes Venter

Senior Software Developer, Jembi Health Systems | SOUTH AFRICA

Mobile: +27 73 276 2848 | Office: +27 21 701 0939 | Skype: venter.johannes

E-mail: hannes@jembi.org

On Mon, Oct 6, 2014 at 11:40 AM, Martin Brocker martin@jembi.org wrote:

Hi Pau

I am including the mailing list in this response again to have a few more eyes looking at what could be causing this issue.
@Hannes @Duma have any of you guys run into this issue before and maybe know what could be causing it?

Warm reagrds,

Martin

On Mon, Oct 6, 2014 at 11:02 AM, Pau Racelis pau.racelis@gmail.com wrote:

I ran the ‘npm test’ and this happened

On Mon, Oct 6, 2014 at 1:43 AM, Martin Brocker martin@jembi.org wrote:

Hi Pau

From what I can see on your last screenshot, you have started the core server correctly and is running. You can test this by running ‘npm test’

Can you also just include the openHIE mailing list to reach a greater audience for assistance with any issues.

Warm Regards,

Martin

On Mon, Oct 6, 2014 at 10:37 AM, Pau Racelis pau.racelis@gmail.com wrote:

also when I typed “node --harmony lib/server.js” this is what’s showing.

On Mon, Oct 6, 2014 at 1:28 AM, Pau Racelis pau.racelis@gmail.com wrote:

Hi!
I have another question, about the “cake watch” https://github.com/jembi/openhim-core-js What should we be seeing? Is this right?

On Mon, Oct 6, 2014 at 12:57 AM, Martin Brocker martin@jembi.org wrote:

Hi Pau

The screenshot error message indicates to me that the module ‘load-grunt-tasks’ could not be found. This could be because it has not been installed. Can you confirm that you have followed the steps as indicated in the Developer Guide?

https://github.com/jembi/openhim-console

If all steps are followed correctly the installation should work without any problems.

Warm Regards,

Martin

On Mon, Oct 6, 2014 at 9:21 AM, Pau Racelis pau.racelis@gmail.com wrote:

Hi, Sir Martin!

I have a question to ask with regards to the installation of OpenHIM Console webapp. I have encountered this problem while following the steps. I cannot run the “grunt test” I am receiving this error. Thank you for your help!

Hi everyone! Thank you for the responses

Hi this is my new error when I entered ‘npm test’ I don’t know what to do next.

Screenshot (74).png

Screenshot (75).png

···

On Mon, Oct 6, 2014 at 4:50 AM, Pau Racelis pau.racelis@gmail.com wrote:

Hi everyone! Thank you for the responses

Hi Pau,

The unit tests run directly against a Mongo database instance, and sounds like this instance might be in an inconsistent state.

The best would be to just drop the test instance and try again - in bash you can just do the following:

$ mongo

use openhim-test

db.dropDatabase()

This is safe to do since this is another instance to the one the HIM will use when running live, so you won’t lose any important data :slight_smile:

Cheers

Hannes

···

On 6 October 2014 14:00, Pau Racelis pau.racelis@gmail.com wrote:

Hi this is my new error when I entered ‘npm test’ I don’t know what to do next.


Hannes Venter

Senior Software Developer, Jembi Health Systems | SOUTH AFRICA

Mobile: +27 73 276 2848 | Office: +27 21 701 0939 | Skype: venter.johannes

E-mail: hannes@jembi.org

On Mon, Oct 6, 2014 at 4:50 AM, Pau Racelis pau.racelis@gmail.com wrote:

Hi everyone! Thank you for the responses

Did you drop the openhim-test database?

regards,

Duma Mtungwa

···

On Mon, Oct 6, 2014 at 2:00 PM, Pau Racelis pau.racelis@gmail.com wrote:

Hi this is my new error when I entered ‘npm test’ I don’t know what to do next.

On Mon, Oct 6, 2014 at 4:50 AM, Pau Racelis pau.racelis@gmail.com wrote:

Hi everyone! Thank you for the responses